Mazda 3 Forums UK

General Category => Mazda 3 => Topic started by: bobmax on June 12, 2021, 09:26:57 AM

Title: I-stop?
Post by: bobmax on June 12, 2021, 09:26:57 AM
OK, Contentious question.

My I-stop isn't working again.

I fitted a new battery several weeks ago, and waited a few days for it to marry into the car.
The I-stop then worked  OK, but after a day or two, it didn't.
I don't wanna go to Mazda. So any ideas on how to get it going again, please?

Title: Re: I-stop?
Post by: Willpower on June 12, 2021, 03:24:43 PM
Firstly there is ( I believe ) an i-stop button which can disable the function.  so that would be my first step.

Next there are a whole host of scenarios where the i-stop will not engage. 
Here are just a few. the rest should all be in your handbook.

1. The second battery used for the i-stop function is not fully charged  (this is a separate battery from the normal one)
2.  The de mister is set to screen and the fan is operating. -Strange one I know but it is to avoid undue strain on the battery at a standstill.
3.  The front wheels are not aligned in the fully front position.  - This is to avoid any lateral movement on engine restart.
4.  The engine isn't warm enough (in winter)
5.   I have heard that i-stop will not work if the engine (diesel) is going through a regeneration

There are others

Try reading previous posts about i-stop for instance. Do a search from the main page.

http://www.mazda3forums.co.uk/index.php?topic=15355.msg117325#msg117325
Title: Re: I-stop?
Post by: qbanista on June 15, 2021, 12:50:10 PM
Other things to consider:

- Is your new battery EFB type?
If it's not, it might cause compatibility issues within the ECU, or simply be too weak to hold enough charge for the i-stop to work.

- Have you followed the handbook procedure when replacing the battery?
There is a specific i-stop reset procedure. It also involves reading and clearing error codes, which can be done with an OBD scanner tool.

- Simply wait a little longer?
I've noticed that the i-stop system is quite fastidious, it might take a couple weeks of driving until it reaches its 'optimal operating conditions'.
Title: Re: I-stop?
Post by: bobmax on June 15, 2021, 12:58:43 PM
thanks for the reply.
Yes, I was informed to wait as you say.
so will wait and see. :D
Title: Re: I-stop?
Post by: bobmax on June 16, 2021, 10:19:38 AM
Other things to consider:

- Is your new battery EFB type?
If it's not, it might cause compatibility issues within the ECU, or simply be too weak to hold enough charge for the i-stop to work.

- Have you followed the handbook procedure when replacing the battery?
There is a specific i-stop reset procedure. It also involves reading and clearing error codes, which can be done with an OBD scanner tool.

- Simply wait a little longer?
I've noticed that the i-stop system is quite fastidious, it might take a couple weeks of driving until it reaches its 'optimal operating conditions'.

I didn't mention in my last post that when I asked about my new battery I was told it's a stop/start one.
Not sure about EFB tech.
Title: Re: I-stop?
Post by: bobmax on July 01, 2021, 07:05:33 PM
no worries guys, it's working again.
just needed to bed in I guess. ::)