Author Topic: 2014, 2.0, Heater not working  (Read 229 times)

0 Members and 1 Guest are viewing this topic.

Offline Richie20.5

  • S Class
  • *
  • Posts: 1
  • Gender: Male
  • I need to update my signature strip!!!
  • Body: Hatchback
  • Colour: Soul Red Metallic (41V)
  • Engine: 2.0L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Sport
  • Year: 2014
2014, 2.0, Heater not working
« on: November 20, 2019, 08:13:51 PM »
Hi, im new to the forum so please excuse me if this is a regular question.
My heater is blowing out cold air but minimal warm air comes out if fan is off.
Coolant is fine, no leaks but have noticed one of the matrix pipes is cold half way along (nearest end to firewall).
Any advice or suggestions would be greatly appreciated.
Richie.

Offline Willpower

  • Administrator
  • Super Ultimate Class
  • *
  • Posts: 6530
  • Gender: Male
  • East Anglia Mountain Rescue Team
  • Body: Saloon
  • Colour: Winning Blue (27B) Metallic
  • Engine: 2.0L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Sport
  • Year: 2004
Re: 2014, 2.0, Heater not working
« Reply #1 on: December 04, 2019, 02:52:01 PM »
As you have had no other answers to this , I would just say that the ventilation system is not a heater per se.  It is Air Conditioning . I would suggest that the temperature that you have set is being maintained, but if you require a boost in cabin temp then the blower/fan is a quick fix.  A more permanent higher temperature can be obtained by changing your set temperature and distribution configuration.
Look at life through the windscreen, not the rearview mirror.
2004 Winning Blue 2Ltr Sport Saloon.  Laser Blue Main beams.

Offline speedy mazda

  • Sports Class
  • ****
  • Posts: 256
  • Gender: Male
  • zoooom zooom zoooooooooooooooom
  • Body: Hatchback
  • Colour: Aluminium Silver (38P) Metallic
  • Engine: 1.6L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Sport
  • Year: 2010
Re: 2014, 2.0, Heater not working
« Reply #2 on: December 04, 2019, 05:20:57 PM »
If you google the fault it’s common and usually it’s the end of the cable come unhooked due to vibration.

Mazda 3 Forums UK

Re: 2014, 2.0, Heater not working
« Reply #2 on: December 04, 2019, 05:20:57 PM »