Author Topic: Something strange with my radio  (Read 708 times)

0 Members and 1 Guest are viewing this topic.

Offline moozmooz

  • Sports Class
  • ****
  • Posts: 364
  • Gender: Male
  • Body: Hatchback
  • Colour: Blue Reflex Mica (42B)
  • Engine: 2.0L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: SE L Nav
  • Year: 2016
Something strange with my radio
« on: March 26, 2018, 12:23:38 PM »
Odd thing happened with my radio. It was on an FM channel and I was driving along at less than 20mph when I heard a noise that initially I thought was something hitting the car, but was actually a sharp pop through the speakers. The sound from the radio died. The display stayed on but it had switched to DAB with a channel number marker on screen. When I got home, I tried switching everything off/on a couple of times, changed channels and still no sound.

After much twiddling and cursing, I screwed up the volume, and back it came.

So the questions. What caused the pop, why did it go to DAB, and what zeroed the volume. First thoughts would have been a reboot of some sort but the display never went off and there was no delay. I played back footage on the dash cam and you can clearly hear the pop through the speakers, but there's no sign of any electrical problem such as picture break up or noise on sound other than the pop.
« Last Edit: March 26, 2018, 12:26:55 PM by moozmooz »

Mazda 3 Forums UK

Something strange with my radio
« on: March 26, 2018, 12:23:38 PM »