Author Topic: AMB Temperature display just showing 3 dashes.  (Read 768 times)

0 Members and 1 Guest are viewing this topic.

Offline Tomk3

  • S Class
  • *
  • Posts: 5
  • Gender: Male
  • Body: Hatchback
  • Colour: Copper Red Mica (32V) Metallic
  • Engine: 1.6L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Takara
  • Year: 2008
AMB Temperature display just showing 3 dashes.
« on: January 09, 2018, 07:03:46 AM »
Hi all,
I've recently bought a 2006 Mazda 3 TS in Aurora Blue, for the first few weeks of owning the car the ambient temperature would show on my display when I pressed the button, however 3/4 days ago when I pressed this button I simply got 3 dashes ??
Can anyone help? Is it a big fix, if any fix at all???
Thanks,
Tom

Offline marcddsa

  • TS Class
  • **
  • Posts: 27
  • Gender: Male
  • I guess I should update my signature strip!!!
  • Body: Hatchback
  • Colour: Carbon Grey (28B) Metallic
  • Engine: 1.4L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: S
  • Year: 2008
Re: AMB Temperature display just showing 3 dashes.
« Reply #1 on: January 09, 2018, 12:37:23 PM »
This could possibly be due to a faulty ambient temp sensor, circuit or maybe just the sensor unplugged..  I would check where mine is but the weather is ******e :(  but I think the sensor sits in front of the radiator...

Offline Willpower

  • Administrator
  • Super Ultimate Class
  • *
  • Posts: 6471
  • Gender: Male
  • East Anglia Mountain Rescue Team
  • Body: Saloon
  • Colour: Winning Blue (27B) Metallic
  • Engine: 2.0L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Sport
  • Year: 2004
Re: AMB Temperature display just showing 3 dashes.
« Reply #2 on: January 09, 2018, 12:49:50 PM »
The sensor is indeed at the front of the engine compartment just behind the grille. There is a connection to the wiring loom which could conceivably become dislodged.  I would suggest ensuring that it is properly secure and if that does not resolve your problem then it will more than likely be a sensor failure (They don't last forever).   Removal and refit is not difficult, however I have no idea on cost. 
Look at life through the windscreen, not the rearview mirror.
2004 Winning Blue 2Ltr Sport Saloon.  Laser Blue Main beams.

Offline Tomk3

  • S Class
  • *
  • Posts: 5
  • Gender: Male
  • Body: Hatchback
  • Colour: Copper Red Mica (32V) Metallic
  • Engine: 1.6L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Takara
  • Year: 2008
Re: AMB Temperature display just showing 3 dashes.
« Reply #3 on: January 09, 2018, 01:11:54 PM »
The sensor is indeed at the front of the engine compartment just behind the grille. There is a connection to the wiring loom which could conceivably become dislodged.  I would suggest ensuring that it is properly secure and if that does not resolve your problem then it will more than likely be a sensor failure (They don't last forever).   Removal and refit is not difficult, however I have no idea on cost.

That explains a lot, a day or so before I noticed it I was driving down a typical English Country road and a pheasant ran out in front of me, I hit said pheasant and cracked the plastic grill, I must of damaged the sensor when this happened!!!

Thanks for the advice!
Thanks,
Tom

Mazda 3 Forums UK

Re: AMB Temperature display just showing 3 dashes.
« Reply #3 on: January 09, 2018, 01:11:54 PM »