Author Topic: My Blackberry's not working!  (Read 3892 times)

0 Members and 1 Guest are viewing this topic.

Offline a15cro

  • Senior Member
  • Super Ultimate Class
  • *
  • Posts: 4451
  • Gender: Male
  • Body: Hatchback
  • Colour: True Red (A4A) Metallic
  • Engine: 2.3L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: MPS
  • Year: 2007
2017 Ford Ranger Wildtrack 3.2 auto, Westfield SeiW Zetec st170 Blacktop & 1980 Chevy Camaro Z28 5.7 V8.

Offline Samp!

  • Super Ultimate Class
  • ********
  • Posts: 3772
  • Gender: Male
  • MX5 MK1 AND MK3.5 NOT A MAZDA 3 BUT STILL A MAZDA!
Re: My Blackberry's not working!
« Reply #1 on: January 29, 2012, 10:38:46 AM »
haha!
USED TO HAVE: MAZDA 3 1.6 SPORT NAV IN ALUMINUM WITH EIBACH SPRINGS AND CUSTOM CORKSPORT SRI INTAKE

NOW HAVE: 1. MX5 MK1 1.8 IN BRITISH RACING GREEN LOTS OF MODS
                 2. MAZDA MX5 SPORT BLACK IN WHITE NO 384 OF 500 EIBACH SPRINGS, K&N PANEL FILTER & LOTS OF LITTLE BITS

Offline Mindis

  • Ultimate Class
  • ******
  • Posts: 1366
  • Gender: Male
Re: My Blackberry's not working!
« Reply #2 on: January 29, 2012, 11:09:06 AM »
I keep watching  this Blackberry and every time it makes me smile :)
Here is another old video, but makes me smile everytime as well :D http://www.youtube.com/watch?v=MNuFcIRlwdc

Offline Stuno1

  • Senior Member
  • Super Ultimate Class
  • *
  • Posts: 4383
  • Gender: Male
  • Lexus isf
  • Body: Saloon
  • Colour: True Red (A4A) Metallic
  • Engine: 1.6L
  • Fuel: Petrol
  • Model: Mazda 3
  • Transmission: Manual
  • Trim: Sport
  • Year: 2006
Re: My Blackberry's not working!
« Reply #3 on: January 29, 2012, 12:08:17 PM »
Top clip :0)
Who needs 4 wheels when you have 2??? Bike it baby!!!!

Mazda 3 Forums UK

Re: My Blackberry's not working!
« Reply #3 on: January 29, 2012, 12:08:17 PM »